Jump to content
Tuts 4 You
Sign in to follow this  
Dragon Palace

I find a bug in font setting

Recommended Posts

Dragon Palace

when I setting the font, it says setting saved, but when I restart x32_dbg.exe, it restored default setting, my os is chinese x64 win 7 ultimate.


 


will you fix it?


Share this post


Link to post
Artic

in x64 version you get the same error. hope we will get a fix soon.


Share this post


Link to post
mrexodia

Hey guys, unfortunately I cannot reproduce your problem... Does any of your font name contain chinese or other non-ascii characters?

Greetings

Share this post


Link to post
Dragon Palace

OK, find the reason, because font is none english, so can't save, I think unicode version must implement now, like OllyDBG, support unicode strings.


Share this post


Link to post
Artic

ill check later, busy atm.


Share this post


Link to post
mrexodia

@DragonLoft: Implementing UNICODE is not as easy as it sounds. It would require a complete rewrite of x64_dbg, something I'm not prepared to right now actually, since I first want to have most requested features done.

Greetings

Share this post


Link to post
Artic

nevermind i was wrong, its working here.


 


for the chinese people the solution is to setup your windows in English too, download the language pack. but im sure some apps still remain with unicode symbols.


Share this post


Link to post
mrexodia

If you really need to use a chinese-named font, just export it and import it under another (non-chinese) name, that will work.


 


Greetings


Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×
×
  • Create New...