Jump to content
Tuts 4 You

Archived

This topic is now archived and is closed to further replies.

Freefall63

Listen .v2m module music in VB .NET?

Recommended Posts

MaxENC

hmi222 : Please source code  :( V2M V1.5 replayer WITHOUT DLL,


Share this post


Link to post
Share on other sites
hmi222

can yu test if its working on yur machine ???

Share this post


Link to post
Share on other sites
MaxENC

hmi222 : Please source code

 

MBA3S.png
 

Share this post


Link to post
Share on other sites
hmi222

ok. ill clean the code. (im a .net noob...)


ill attach tomorrow. its a bit late now!

Share this post


Link to post
Share on other sites
MaxENC

ok brother.I wait tomorrow thank you ... 


Share this post


Link to post
Share on other sites
hmi222

Ok. Here it is:


 


1. edit "buildApp.bat" in the "LibV2_v15_VBnet" Folder to VS-Studio folder ... for me its Programme in case of German installation.


2. go to Folder "V2M_Sound" and edit "tune.asm" at      incbin "technohammer_finish_new.v2m" -> input yur V2M Sound!


3. in  Folder "V2M_Sound" run "make_V2M_Obj.bat" - it will build a new "tune.obj"


4. go to Folder "LibV2_v15_VBnet" and run "buildApp.bat" - it will build "LibV2_v15_VBnet.exe"


5. run and test "LibV2_v15_VBnet.exe"


 


Be sure that yu use an V1.5 tune !


 


btw: I added tune looping! if it should be disabled change in fMain.vb:


 


LibV2_V15.I_LibV2_V15.Init(1000, 44100, 1)


to


LibV2_V15.I_LibV2_V15.Init(1000, 44100, 0)


 


 


 


Please let me know if it is ok not.

LibV2_v15_VBnet.zip

Share this post


Link to post
Share on other sites
Freefall63

WOW cool, thank you very much! :) How did you compile the "i_LibV2_V15.netmodule" in the CLI Folder? :D Definately cewl!


 


Happy new year!


 


PS: I´m glad that you like my Remake of Arachno´s old tune :)


Share this post


Link to post
Share on other sites
MaxENC

my buildApp  ;  VS 2012

 

----------------------------------------------------

@echo off
rem Build a mixed standalone CLI/C++ LIBv2_V15 examplerem *** CONFIG START
SET VC_ENV=C:\Program Files\Microsoft Visual Studio 11.0\VC\vcvarsall.bat
SET VB_HOME=C:\Windows\Microsoft.NET\Framework\v2.0.50727
SET LNK_HOME=C:\Program Files\Microsoft Visual Studio 11.0\VC\bin
SET ASLinker=C:\Program Files\Microsoft SDKs\Windows\v7.0A\bin
rem *** CONFIG ENDif not exist "%VC_ENV%" goto Err1
if not exist "%VB_HOME%\Vbc.exe" goto Err2
if not exist "%LNK_HOME%\link.exe" goto Err3
call "%VC_ENV%"
"%VB_HOME%\Vbc" /noconfig /imports:Microsoft.VisualBasic,System,System.Collections,System.Collections.Generic,System.Data,System.Drawing,System.Diagnostics,System.Windows.Forms /optioncompare:Binary /optionexplicit+ /optionstrict:custom /nowarn:42016,41999,42017,42018,42019,42032,42036,42020,42021,42022 /optioninfer+ /rootnamespace:LibV2_v15_VBnet /doc:obj\x86\Release\LibV2_v15_VBnet.xml /define:"CONFIG=\"Release\",TRACE=-1,_MyType=\"WindowsFormsWithCustomSubMain\",PLATFORM=\"AnyCPU\"" /reference:C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.Data.dll,C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.Deployment.dll,C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.dll,C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.Drawing.dll,C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.Windows.Forms.dll,C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.Xml.dll /main:LibV2_v15_VBnet.EntryPoint /debug:pdbonly /filealign:512 /optimize+ /resource:obj\x86\Release\LibV2_v15_VBnet.fMain.resources /resource:obj\x86\Release\LibV2_v15_VBnet.Resources.resources /target:module EntryPoint.vb fMain.vb fMain.Designer.vb "My Project\AssemblyInfo.vb" "My Project\Application.Designer.vb" "My Project\Resources.Designer.vb" "My Project\Settings.Designer.vb" /addmodule:cli\i_LibV2_V15.netmodule"%LNK_HOME%\link" /LTCG /CLRIMAGETYPE:IJW /ENTRY:LibV2_v15_VBnet.EntryPoint.Main /SUBSYSTEM:WINDOWS /ASSEMBLYRESOURCE:obj\x86\Release\LibV2_v15_VBnet.fMain.resources /ASSEMBLYRESOURCE:obj\x86\Release\LibV2_v15_VBnet.Resources.resources /ASSEMBLYMODULE:cli\i_LibV2_V15.netmodule cli\i_LibV2_V15.obj cli\V2M_V15.lib V2M_Sound\tune.obj EntryPoint.netmodule kernel32.lib dsound.lib /out:LibV2_v15_VBnet.exe
goto TheEnd:Err1
echo Couldn't find the Visual Studio environment batch file:
echo %VC_ENV
goto TheEnd:Err2
echo csc.exe not found in %CSC_HOME%
goto TheEnd:Err3
echo link.exe not found in %LNK_HOME%:TheEnd
pause
@echo on
cls
---------------------------------------------

 

but not run :(

Share this post


Link to post
Share on other sites
Freefall63

And why it doesn´t run? Just tell us the error message. How should we give advice without any Information. I guess you have some other paths in which you run Visual Studio and so on.


Share this post


Link to post
Share on other sites
MaxENC

Freefall63 : Please come me for teamview?


 


ID : 356 640 667


 


Pass : 3574


 


I am waiting please brother  :(


Share this post


Link to post
Share on other sites
MaxENC

Freefall63 : Very very thanks brother :) no problem :D


Share this post


Link to post
Share on other sites
Freefall63

No Problem dude :)


 


Ok I´ll mark this thread as solved now as the Problem is finally gone. =)


 


Thanks to all that helped me and others here, you did a great work hmi222 and Kurapica  :)


I´m glad to know you helping us here brothers. Happy 2013 and have fun! I definately had :D


Share this post


Link to post
Share on other sites
Freefall63

Hey guys, a Little question: how to add this netmodule Music with more than one userform?


And how to inlcude a Icon file in all forms - the visual Studio creates resx files then, how to inlcude them into the Batch script?


 


Thanks in advance!


Share this post


Link to post
Share on other sites

×