Jump to content
Tuts 4 You

Tweaking Cdma Modem


Recommended Posts

I am using CDMA mobile phone for connectiong to the internet. The default speed is 115200kbs. Under Linux i can modifiy speed of this connection upto 230400kbs by editting config files. Same can be done on MAC.

However i need to run it under Windows XP and there in modem properties in "port speed" section the limit is the default 115200kbs. In .inf file there is higher speed but windows doesnt give this option. How could i tweak it to 230400kbs?

C:\WINDOWS\inf\oem15.inf

HKR, Responses, "CONNECT 57600", 1, 02, 00, 00,00,00,00, 00,E1,00,00

HKR, Responses, "CONNECT 57600/ARQ", 1, 02, 02, 00,00,00,00, 00,E1,00,00

HKR, Responses, "CONNECT 57600/REL", 1, 02, 02, 00,00,00,00, 00,E1,00,00

HKR, Responses, "CONNECT 57600/MNP", 1, 02, 02, 00,00,00,00, 00,E1,00,00

HKR, Responses, "CONNECT 57600/LAP-M", 1, 02, 02, 00,00,00,00, 00,E1,00,00

HKR, Responses, "CONNECT 57600/V42BIS", 1, 02, 03, 00,00,00,00, 00,E1,00,00

HKR, Responses, "CONNECT 57600/V42b", 1, 02, 03, 00,00,00,00, 00,E1,00,00

HKR, Responses, "CONNECT 115200", 1, 02, 00, 00,00,00,00, 00,C2,01,00

HKR, Responses, "CONNECT 115200/ARQ", 1, 02, 02, 00,00,00,00, 00,C2,01,00

HKR, Responses, "CONNECT 115200/REL", 1, 02, 02, 00,00,00,00, 00,C2,01,00

HKR, Responses, "CONNECT 115200/MNP", 1, 02, 02, 00,00,00,00, 00,C2,01,00

HKR, Responses, "CONNECT 115200/LAP-M", 1, 02, 02, 00,00,00,00, 00,C2,01,00

HKR, Responses, "CONNECT 115200/V42BIS", 1, 02, 03, 00,00,00,00, 00,C2,01,00

HKR, Responses, "CONNECT 115200/V42b", 1, 02, 03, 00,00,00,00, 00,C2,01,00

HKR, Responses, "CONNECT 115,200", 1, 02, 00, 00,00,00,00, 00,C2,01,00

HKR, Responses, "CONNECT 115,200/ARQ", 1, 02, 02, 00,00,00,00, 00,C2,01,00

HKR, Responses, "CONNECT 115,200/REL", 1, 02, 02, 00,00,00,00, 00,C2,01,00

HKR, Responses, "CONNECT 115,200/MNP", 1, 02, 02, 00,00,00,00, 00,C2,01,00

HKR, Responses, "CONNECT 115,200/LAP-M", 1, 02, 02, 00,00,00,00, 00,C2,01,00

HKR, Responses, "CONNECT 115,200/V42BIS", 1, 02, 03, 00,00,00,00, 00,C2,01,00

HKR, Responses, "CONNECT 115,200/V42b", 1, 02, 03, 00,00,00,00, 00,C2,01,00

HKR, Responses, "CONNECT 230400", 1, 02, 00, 00,00,00,00, 00,84,03,00

HKR, Responses, "CONNECT 230400/ARQ", 1, 02, 02, 00,00,00,00, 00,84,03,00

HKR, Responses, "CONNECT 230400/REL", 1, 02, 02, 00,00,00,00, 00,84,03,00

HKR, Responses, "CONNECT 230400/MNP", 1, 02, 02, 00,00,00,00, 00,84,03,00

HKR, Responses, "CONNECT 230400/LAP-M", 1, 02, 02, 00,00,00,00, 00,84,03,00

HKR, Responses, "CONNECT 230400/V42BIS", 1, 02, 03, 00,00,00,00, 00,84,03,00

HKR, Responses, "CONNECT 230400/V42b", 1, 02, 03, 00,00,00,00, 00,84,03,00

Any ideas? :)

Edited by JaZoo
Link to comment
So u use Reliance :)

I am looking for the same thing.. but no luck

Yep, Reliance :P pay premium and get lousy speed :P

If you work it out how to do it then let me know. It would be great to make it a go faster :)

Link to comment
undertaker
Yep, Reliance :P pay premium and get lousy speed :P

0)

But tweaking the way u post on Linux does it increase the speed.

I am using XP sp2 firewall off and 1 night i get horrible speed

115mj.jpg

and it was for whole night i have not done any tweaking.

I think you should come join this forum

_http://www.rimweb.in

This is for Reliance discussion forum meant for these type of discussion only. I even posted this over there

Link to comment

Yep, Reliance :P pay premium and get lousy speed :P

0)

But tweaking the way u post on Linux does it increase the speed.

I am using XP sp2 firewall off and 1 night i get horrible speed

and it was for whole night i have not done any tweaking.

I think you should come join this forum

_http://www.rimweb.in

This is for Reliance discussion forum meant for these type of discussion only. I even posted this over there

At least in the place I stay Reliance service is not steady, sometimes good speed sometimes bad, too many users I guess.

Average download speed I get is 10.0-11.0 kb/s. On linux after tweaking I was getting 16 kb/s on average, so quite a difference.

Link to comment
undertaker

how to get 230kbps speed via genuine usb cable? Rconnect

first download the drivers from the following link http://www.mev.co.uk/zip/usb_232_485_drivers.zip

this drivers only work with the original cable

now unzipped the file

now search the FTDIPORT.INF

IN THE FILE U WILL FIND THE FOLLOWING TO ENTRIES

1. [FtdiPort232.HW.AddReg]

HKR,,ConfigData,1,01,00,3F,3F,10,27,88,13,C4,09,E2,04,71,02,38,41,9c,80,4E,C0,34

,00,1A,00,0D,00,06,40,03,80,00,00,d0,80

2.[FtdiPort232.NT.HW.AddReg]

HKR,,"UpperFilters",0x00010000,"serenum"

HKR,,"ConfigData& quot;,1,01,00,3F,3F,10,27,88,13,C4,09,E2,04,71,02,38,41,9c,80,4E,C0,34,00,1A,00,

0D,00,06,40,03,80,00,00,d0,80

NOW IN THE ABOVE BOTH ENTRIES

REPLACE 1A,00 WITH 0D,00

NOW THE INF FILE IS MODIFIED

THIS WORKS IN THE FOLOWING WAY

IN THE WINDOWS VIRTUAL COMM THE SPEED 115,200 IS REPLACED BY

230,400

NOW WHEN U SELECT 115,200 IN THE COM PORT SETTINGS THE BAUD RATE IS

SET TO 230,400

NOW GO IN DEVICE MANAGER UNDER UNIVERSIAL SERIAL BUS CONTROLLERS

SELECT USB TO SERIAL CONTROLLER

NOW UPDATE THE DRIVERS MANUALLY BY GIVING THE LOACTION WHERE U

HAVE DOWNLOADED THE MODIFIED DRIVERS

AFER IT ALSO UPGRADE THE DRIVERS FOR USB SERIAL PORT MANUALLY

BY GIVING LOCATION OF THE MODIFIED FTDIPORT.INF FILE

NOW EVERYTHING IS OK ON THE COMPUTER SIDE

DO THE ABOVE PROCEDURE WHEN THE CABLE AND THE PHONE ARE CONNECTED

TO THE PC.

NOW REMOVE THE CABLE AND RESTART THE PC

AND SELECT THE BAUD RATE IN THE PHONE TO 230,400

NOW THE PHONE WOULD BE ABLE TO CONNECT AT 230,400

SEND YOUR REPLY

Also read this

Spoofing Baud Rates for USB232 and USB485i

[b]http://www.mev.co.uk/usbbaudspoof.htm

Edited by undertaker
Link to comment

Thanks :thumbsup: i will try it out tomorrow :D BTW did u test it? and where did u find this info?

Edited by JaZoo
Link to comment
undertaker

No i don't have Genuine cable :( and it is clearly mentioned it will be supported by Genuine cable as it has something which is not in duplicate cable and i don't want to even purchase new as my old 2 years back purchased cable is working perfectly. :)

I find this info at rimweb.in

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...