Jump to content
Tuts 4 You
Sign in to follow this  
LCF-AT

Firefox disabled all AddOns!

Recommended Posts

LCF-AT

Hi guys,

today I stated Firefox and after few minutes it did disabled all AddOns / Themes!On internet I found any infos about that problem.

https://www.zdnet.com/article/firefox-add-ons-disabled-en-masse-after-mozilla-certificate-issue/

https://news.ycombinator.com/item?id=19823465

https://www.ghacks.net/2019/05/04/your-firefox-extensions-are-all-disabled-thats-a-bug/

Uhhhm!What a BS!I could puke all over the place.Men men men men men Mozilla!What a own goal!I am really getting angry more and more with that browser. :(

PS: Still no update fix out yet for normal FF users.

greetz

Share this post


Link to post
NOP

You can disable addon signing in the nightly / developer versions which fixes the problem

I too use firefox and a lot of addons which nearly all have now been disabled šŸ¤£

Ā 

I'll try the suggested fixes when I get time...

Share this post


Link to post
LCF-AT

I dont use a nigļ»æhtly / developer version only the normal version. :) Like the most users.Setting the value of..

xpinstall.signatures.required to false dosent work there.I had this already to false before.

Also I dont wanna edit the extensions.json file like this..

Shut down Firefox
Open extensions.json
Rreplace all instances of ā€œappDisabledā€: false to ā€œappDisabledā€: true
Replace all instances of ā€œsignedStateā€: -1 to ā€œsignedStateā€: 2
Save and start browser
Disable and re-enable all extensions in about:addons
Hope they donā€™t break it again

....just need to wait till a update to fix that trash.Lets see how long they need and in the mean time we can use a other browser or drink coffee and sing this.... :)

greetz

Share this post


Link to post
[L]over

Options -> Privacy & Security -> Firefox Data Collection and Use -> Enable and Disable "Allow Firefox to install and run studies"

It installs the hotfix.

  • Like 1

Share this post


Link to post
LCF-AT

Hi [L]over,

thanks for this info.For my main FF browser it did work so far with your hint.Another problem is how to deal with older FF versions in that case?I am also using FF 56.0.2 and there I got disabled AddOns too like uBlock and this browser dosent have such setting like the lastest to got those fixes.

Now I dont have access on my uBlock user filter settings in Firefox itself.Uhhhm!

PS: I hope they will fix that problem so that I can also use my older Firefox with my AddOns and all settings I made.

greetz

Share this post


Link to post
Teddy Rogers

How did they miss this glaring problem before release?

Ted.

Share this post


Link to post
[L]over

Hey LCT-AT, you need to download the hotfix and install it yourself until they finish the definitive patch (unless there is something similar in this version).

Mozilla let me down this time.

Share this post


Link to post
NOP
9 hours ago, Teddy Rogers said:

How did they miss this glaring problem before release?

Ted.

I was thinking the same, surely it must have been tested before release...

I love Firefox probably 99% because of the addons, i'm sure this problem was the final straw for some firefox users and i'm sure some ppl will have switched browsers but i'm just happy they are all working again :)

Share this post


Link to post
deepzero

Problem was an expired code signing certificate...

Share this post


Link to post
LCF-AT

Hi guys,

thanks for feedback about that problem and posting a workaround solution.The hotfix seems to work so far for latest FF version.For my older FF I had also to edit the extensions.json file to get all AddOns enabled (works). :)

greetz

Share this post


Link to post
LCF-AT

Hi again,

I got a new problem using my old FF 56.0.2 version.As I told before the hotfix AddOn was working also in this version for few AddOns but not all.For the others like uBlock I had to edit the extension.json file like you can see in my second post in this thread.After this I could enable the other AddOns again.Now after using the old FF version for a while I got again this AddOn popup message from Firefox above what told me that AddOns was disabled etc and now I get same problem as before again.Only thing I could do was to edit the extension.json file in profile folder and setting it then to write protected but also in this case I got the same AddOn disabled message again and I had to re-start Firefox and all AddOns was there and usable again.Now my question is how to disable this AddOn verfiy thing in Firefox to prevent getting this problem again after a while of using this Firefox older version?Is there any specific URL address Firefox does call to check the verfiy state of the AddOns?If yes then I could maybe disable this URL in uBlock etc.Maybe anyone does know this.

greetz

Share this post


Link to post
NeWOT
13 minutes ago, LCF-AT said:

Hi again,

I got a new problem using my old FF 56.0.2 version.As I told before the hotfix AddOn was working also in this version for few AddOns but not all.For the others like uBlock I had to edit the extension.json file like you can see in my second post in this thread.After this I could enable the other AddOns again.Now after using the old FF version for a while I got again this AddOn popup message from Firefox above what told me that AddOns was disabled etc and now I get same problem as before again.Only thing I could do was to edit the extension.json file in profile folder and setting it then to write protected but also in this case I got the same AddOn disabled message again and I had to re-start Firefox and all AddOns was there and usable again.Now my question is how to disable this AddOn verfiy thing in Firefox to prevent getting this problem again after a while of using this Firefox older version?Is there any specific URL address Firefox does call to check the verfiy state of the AddOns?If yes then I could maybe disable this URL in uBlock etc.Maybe anyone does know this.

greetz

1. open firefox

2. go to about:config

3. search forĀ xpinstall.signatures.required

4. set it to false

like here:Ā ttt.png.0c895fe4f939badf321a101f08791a7e.png

5. ???

6. profit

Ā 

Share this post


Link to post
LCF-AT

Hi,

its already set to false from the beginning but this dosent work only for Dev & Nightly FF versions.I tried to use a Dev FF 56.x version where its working but this browser is bad and cant also bypass my Firewall by itself like normal browsers.Also this Dev versions has some other bad issues too and I wanna keep using the official releases.

What are my options if I want to install unsigned extensions in Firefox?

    The Nightly and Developer Edition versions of Firefox have a preference to disable signature enforcement. There are also be special unbranded versions of Release and Beta that have this preference, so that add-on developers can work on their add-ons without having to sign every build. To disable signature checks, you will need to set the xpinstall.signatures.required preference to "false".
        type about:config into the URL bar in Firefox
        in the Search box type xpinstall.signatures.required
        double-click the preference, or right-click and selected "Toggle", to set it to false.

I am using offical release.

xpiI.png.866314ca52df9016cdcbc9765d670a0e.png

Where its already set to false by me before.As I said the "hotfix-update-xpi-intermediate@mozilla.com-1.0.2-signed.xpi" file dosent work for all AddOns in older FF versions.

greetz

Share this post


Link to post
MANMOHAN81

Mozilla has just released another updateĀ 66.0.5 for Firefox browser to resolve other issues related to the extension bug discoveredļ»æļ»æļ»æļ»æĀ last week.

Share this post


Link to post
LCF-AT

Hi,

good ok but how should this 66.0.5 help with my 56.0.2 Firefox problem? :) Just wanna also use my FF 56.0.2 on same way as I used before that certificate problem where everything was working normaly and now I always get that AddOn message what does disable some AddOns each time so I cant fix that problem manually.Only thing I can do it always to re-start the Firefox and this sucks.The old version I do also use is a portable version with a set of AddOns X (no more supported by Quantum) and thats all.I dont update this version or change any setting there anymore but now I have that disable AddOns message each time.Somehow Mozilla has still not fixed something on they servers about that extension certificate stuff so that I still get disabled using my old version Firefox where I never got that problem before what means that this certificate issue isnt full fixed yet on Mozilla side.If so then I wouldnt get that problem anymore.

PS: Is there any setting / function I can use in old or new Firefox to check manually for the extension certificate?

greetz

Share this post


Link to post
LCF-AT

Hi again,

I found this entry in about:config called...

app.update.lastUpdateTime.xpi-signature-verification

...using Unix timecode.Seems that this always gets checked and then I get my AddOns disabled in Firefox 56.0.2.

U1.png.55945b97a9f11f518002e7d9341848a2.png

U2.png.3077b0f8fab32d0d9eea80fd0e268399.png

Problem is I cant set a higher Unix Timecode into which get saved into prefs.js file.By restart the value is set to 0 and then it does update it again = AddOns disabled right after few seconds.Somehow this entry should be disabled or removed etc not to checked anymore but how.Any ideas?

greetz

Share this post


Link to post
kao
49 minutes ago, LCF-AT said:

I never got that problem before

Hmmmm... Could it be because you didn't do time travel and never experienced 4th of May 2019 before? ;)

52 minutes ago, LCF-AT said:

this certificate issue isnt full fixed yet on Mozilla side.

The expired certificate is insideĀ your outdatedĀ copy of Firefox 56. And, as you said it yourself - you refuse to update it. So, how on earth do you expect Mozilla to fix something that's on your computer? Should they send Santa with magic powers to your home?

Ā 

Solution: download the XPI file from above. Extract files from it. Base64-decode new certificate from api.js.Ā Add new certificate into your old Firefox (Tools-Options-Certificates). Done. Takes less time than writing thoseĀ whiny posts.

Full disclaimer: I couldn't test it 100% because I don't use Firefox on a daily basis and I couldn't find portable Firefox 56 with 3rd party addons.Ā 

  • Like 3
  • Haha 1

Share this post


Link to post
LCF-AT

Hhmm.So I didnt thought that the extension cert had anything to do with the certs in browser etc.I also thought they gets updated extra.So why didnt they just told that straight to use the latest cert from latest FF in older FF.Uhhmm!Its really pretty simple to do this but most dosent know how to explain it simple too.

Good ok,so now it seemsĀ  to work without getting that AddOn disable message again using latest Mozilla cert.Just found also this description how to do these steps manually.

https://support.mozilla.org/en-US/questions/1258165#answer-1218833

Just doing a export from latest & import to older version.That was really easy.

Thanks for that info kao,so with that I could find the more detailed simple description by jscher2000.Men men men you,what a hard birth again! :slap:

greetz

Ā 

Share this post


Link to post
yano65bis
Posted (edited)
On 5/4/2019 at 8:34 PM, LCF-AT said:

Hi guys,

today I stated Firefox and after few minutes it did disabled all AddOns / Themes!On internet I found any infos about that problem.

https://www.zdnet.com/article/firefox-add-ons-disabled-en-masse-after-mozilla-certificate-issue/

https://news.ycombinator.com/item?id=19823465

https://www.ghacks.net/2019/05/04/your-firefox-extensions-are-all-disabled-thats-a-bug/

Uhhhm!What a BS!I could puke all over the place.Men men men men men Mozilla!What a own goal!I am really getting angry more and more with that browser. :(

PS: Still no update fix out yet for normal FF users.

greetz

Hi

try to restore the default settingsĀ  by Accessing the Troubleshooting Information page : type : about:support in Firefox address bar > Give Firefox a tune up >Ā  refresh firefox

https://support.mozilla.org/en-US/kb/use-troubleshooting-information-page-fix-firefox#w_accessing-the-troubleshooting-information-page

OR

https://support.mozilla.org/en-US/products/firefox/fix-problems/problems-add-ons-plugins-or-unwanted-software

Ā 

Ā 

Edited by yano65bis (see edit history)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×
×
  • Create New...