Jump to content
Tuts 4 You

Opera Sandboxie Extension install problems


Recommended Posts

Hi guys,

I wanted to try some other browsers and I see there are a lot I could test.Now I did started with some but have trouble to install extensions in the browser running browser inside of Sandboxie.Here I get always a error message about could not unpack extension. :( If I run browser outside then installing extensions are working.The same problem I had with Vivaldi browser too.Does anyone know how to fix that problem to install enxtension running browser in Sandboxie?No idea why it dosent unpack / install this .nex files.


EDIT: Found another problem using Opera in Sandboxie,also videos will not played like from dailymotion etc. :( Uhhmmm!Also found this thread below,much trouble no solution yet.


Edited by LCF-AT
Link to comment

Hi again,

I have test Vivaldi browser which is next version of Opera and based on Chrome browser.Vivaldi has no problem to play videos which Opera has.Also tried diffrent extensions to install them from Sandboxie and Vivialdi & Opera dosent install them becaus of unpacking issues but with Chrome its working.Next problem I see is if I try to use same Opera / Chrome extensions that they dont work same.In Chrome & Vivaldi isnt allowed to download videos from youtube but with same extension I can download youtube videos in Opera.Totally Bull-dirt. :) Always these stupid limitations here or there sucks.At the moment its really bad to build a custom all in one browser configuration like I want.


Link to comment

Why you using Sandboxie for?? Me and my team thinks it's a piece of trash for the most part. You are a highly technical user, I think Sandboxie is more for non-technical users. You get much more control running browser in VM unless you need specific browser settings to your current machine for some reason. I think Sandboxie is ok for opening malicious PDF/Docs and stuff like that, but not much more.

Edited by null_endian
Link to comment


I think Sandboxie is ok to browse on internet.VM Ware & Co taking to much time to load the OS and reduce my resources a lot.I was just looking for a quicker solution and found Sanboxie some years ago.


  • Like 1
Link to comment

Hi again,

I did checked Opera and Vivaldi browsers again which are almost same.Diffrent is that Opera dosent play videos from the web but Vivaldi does.Below a example of a same video link and the internal infos about it....

Opera = Error and video not playing


error	MFDemuxer: open stream failed  <<-----
frame_url	https://assets.stuff.co.nz/video/production/1451429022625-darts%20best.mp4
origin_url	https://assets.stuff.co.nz/
passed_cors_access_check	false
pipeline_state	kStopped
player_id	0
range_header_supported	true
render_id	25
single_origin	true
streaming	false
total_bytes	19124866
url	https://assets.stuff.co.nz/video/production/1451429022625-darts%20best.mp4

Vivaldi = Does play the video


audio_buffering_state	BUFFERING_HAVE_ENOUGH
audio_dds	false
audio_decoder	PassThroughAudioDecoder
duration	75.392
event	PAUSE
frame_url	https://assets.stuff.co.nz/video/production/1451429022625-darts%20best.mp4
height	368
info	Effective playback rate changed from 0 to 1
origin_url	https://assets.stuff.co.nz/
passed_cors_access_check	false
pipeline_buffering_state	BUFFERING_HAVE_ENOUGH
pipeline_state	kSuspended
platform_pipeline_status_list	0
player_id	0
range_header_supported	true
render_id	28
single_origin	true
streaming	false
total_bytes	19124866
url	https://assets.stuff.co.nz/video/production/1451429022625-darts%20best.mp4
video_buffering_state	BUFFERING_HAVE_ENOUGH
video_dds	false
video_decoder	PassThroughVideoDecoder
width	640

On internet I could found a lot of trouble posts about not playing videos for a long time without any fix.Seems that Opera is pretty bullshit that they didnt fixed that long time problem yet! :slap:


Link to comment
  • 5 months later...

Hi again,

yesterday and today I tried again to work a little with Opera latest version in Sandboxie and see the Problem about playing videos wasnt fixed.I check the Sandboxie forum about the problem (see link above) whether there is anything new and the Admin postet there a way how to handle that problem just using a shortcut command called -no-sandbox for Opera launcher file.So I tried this out and right after start of Opera poping many windows error msg boxes up all with the same error...

  Problemereignisname:	APPCRASH
  Anwendungsname:	opera.exe
  Anwendungsversion:	54.0.2952.64
  Anwendungszeitstempel:	5b57cf71
  Fehlermodulname:	opera_browser.dll
  Fehlermodulzeitstempel:	5b57cf30
  Ausnahmecode:	80000003
  Ausnahmeoffset:	00268ddd

....Opera did keep open and it also did played the videos now.Also I could not open the settings page anymore of Opera etc and the error message also keeps poping up.Now I tried to check this error offset in the opera_browser.dll in Olly and found this code....

$-23     5A608DBA     68 3FF0AC5E         PUSH 0x5EACF03F                         ; ASCII "NtQuerySection"
$-1E     5A608DBF     50                  PUSH EAX
$-1D     5A608DC0     FF15 BCE6815E       CALL DWORD PTR DS:[0x5E81E6BC]          ; kernel32.GetProcAddress
$-17     5A608DC6     A3 D01D4C5F         MOV DWORD PTR DS:[0x5F4C1DD0],EAX
$-12     5A608DCB     68 D41D4C5F         PUSH 0x5F4C1DD4
$-D      5A608DD0     E8 64191C04         CALL 5E7CA739                           ; opera_br.5E7CA739
$-8      5A608DD5     83C4 04             ADD ESP,0x4
$-5      5A608DD8   ^ E9 C5FEFFFF         JMP 5A608CA2                            ; opera_br.5A608CA2
$ ==>    5A608DDD     CC                  INT3               <---- Exception offset
$+1      5A608DDE     0F0B                UD2
$+3      5A608DE0     6A 05               PUSH 0x5
$+5      5A608DE2     CC                  INT3
$+6      5A608DE3     CC                  INT3
$+7      5A608DE4     CC                  INT3
$+8      5A608DE5     CC                  INT3
$+9      5A608DE6     CC                  INT3

$-FC     5A608CE1     6A 00               PUSH 0x0
$-FA     5A608CE3     6A 00               PUSH 0x0
$-F8     5A608CE5     6A 02               PUSH 0x2
$-F6     5A608CE7     8D4E 20             LEA ECX,DWORD PTR DS:[ESI+0x20]
$-F3     5A608CEA     51                  PUSH ECX                                ; ntdll.76F0F700
$-F2     5A608CEB     50                  PUSH EAX
$-F1     5A608CEC     53                  PUSH EBX
$-F0     5A608CED     50                  PUSH EAX
$-EF     5A608CEE     FF15 60E6815E       CALL DWORD PTR DS:[0x5E81E660]          ; kernel32.DuplicateHandle
$-E9     5A608CF4     89C3                MOV EBX,EAX
$-E7     5A608CF6     85C0                TEST EAX,EAX
$-E5     5A608CF8     74 09               JE SHORT 5A608D03                       ; opera_br.5A608D03
$-E3     5A608CFA     FF76 20             PUSH DWORD PTR DS:[ESI+0x20]
$-E0     5A608CFD     FF15 FCE5815E       CALL DWORD PTR DS:[0x5E81E5FC]          ; kernel32.CloseHandle
$-DA     5A608D03     85DB                TEST EBX,EBX
$-D8     5A608D05     0F95C0              SETNE AL
$-D5     5A608D08     837E 0C 00          CMP DWORD PTR DS:[ESI+0xC],0x0
$-D1     5A608D0C     0F94C1              SETE CL
$-CE     5A608D0F     30C1                XOR CL,AL
$-CC     5A608D11     0F84 C6000000       JE 5A608DDD                             ; <---- Jumps to Int3
$-C6     5A608D17     8966 0C             MOV DWORD PTR DS:[ESI+0xC],ESP

....if the DuplicateHandle fails (returns 0) then JE command does jump to 5A608D03 where it does check it again in EBX and SETNE AL gets false = keeps 0 in eax / al.Then its checking ESI+0C for 0 and if so then CL is set to TRUE / 1.After that comes xor cl,al.If both al & cl.If both gets 0 then JE does jump to int3 opcode.

If DuplicateHandle success and ESI+0C is 0 = Error / if ESI+0C not 0 = no Error.If both are 0 = no Error or if al 0 and ESI+0C not 0 = Error jump.So anyhow it dosent logic for me. :) So to make it short.I just nopped the JE jump to int3 opcode and saved it as new opera_browser.dll file into right folder and then I did start the Opera launcher via shortcut with the -no-sandbox paramter after path and Opera starts without problems and without to get any error messages anymore.Video does play well too and also I get no other errors or problem yet.

Of course its just a tiny dirty patch but it seems to work so far for me.Just a feedback from me so maybe anyone does help it too who has same trouble with Opera in Sandboxie or maybe any Opera coder guy/s can use this information to fix that problem in any next version or something like that so that we could use Opera normaly in Sandboxie.


  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...