Jump to content
Tuts 4 You
LCF-AT

Networkcard problems!

Recommended Posts

LCF-AT

Hi guys,

thanks for your feedback so far.

1. I tried this driver already before kao and windows also gave me that one by itself but also get just 100 Mbit/s.

2. About the cable.Before few minutes I tried to connect my cable on laptop computer which also has OnBoard Giga lan.On this laptop I dont get ANY connection to my router and windows always tries to make a connection (icon loading) and it says "No cable connected!=?So that means my cable dosent work on the laptop but it works on my PC but only with that TP-LINK card where I only get 100 MBit/s but it dosent work with my other Realtek cards = same effect like on labtop now!?On labtop I am using XP.

So that really strange.Seems that the problem is really my cat 6 cable but still cant imagine that the cable is damage or something so I didnt do anything with that cable just to connect / disconnect from card to card etc.Hhmmm.But the cable looks ok so far and  the end heads on each end are also ok and have no damage issue so far I can see that from outside.The cable is also just half year old or something.

Is there a way to check that cable anyhow?I am electro person and have no devices to check that anyhow.Only thing I could do is to order new cable.The last time I did order this cable product with 15m lenght...

https://kabeldirekt-store.de/index.php/lightning-cable-slim-1m-3ft-870.html

What now?New cable I should try next or what do you mean guys?

greetz

Share this post


Link to post
Share on other sites
Kurapica

cables malfunction quickly if they are in extreme cold or hot conditions so you may wanna check them.

 

  • Like 1

Share this post


Link to post
Share on other sites
LCF-AT

Hi again,

did you mean not?My cable is just in one room to next room (whole in the wall for the cable) inside only not outside.The temperature is normal but the cable is laying under 2 heaters but this shouldnt be a problem so it was also no problem with my old cable too.

Its already strange that my cable dosent work & work....Labtop = nothing / GBE both cards = nothing / TP LINK = works but only 100 Mbit/s.

I started a tool called HWINFO to get some details of my TP LINK card & my OnBoard Reaktek PCIe FE  Family Controller (my other GBE I have not in PC now).

This are my OnBoard card infos I get..

General information                                                             
Network Card:                                                                   RealTek Semiconductor RTL8101/2/3 Family Fast Ethernet NIC
Vendor Description:                                                             Realtek PCIe FE Family Controller
MAC Address:                                                                    B8-....

Capabilities                                                                    
Maximum Link Speed:                                                             100 Mbps
Transmit Buffer Size:                                                           96896 Bytes
Receive Buffer Size:                                                            775168 Bytes
Hardware ID:                                                                    PCI\VEN_10EC&DEV_8136&SUBSYS_230D1565&REV_05

Driver Information                                                              
Driver Manufacturer:                                                            Realtek
Driver Description:                                                             Realtek PCIe FE Family Controller
Driver Provider:                                                                Realtek
Driver Version:                                                                 7.114.1003.2017
Driver Date:                                                                    03-Oct-2017
DeviceInstanceId                                                                PCI\VEN_10EC&DEV_8136&SUBSYS_230D1565&REV_05\4&ABBF86&0&00E1
This for my TP-LINK card....

General information                                                             
Network Card:                                                                   RealTek Semiconductor RTL8169 Gigabit Ethernet Adapter
Vendor Description:                                                             Realtek PCI GBE Family Controller
MAC Address:                                                                    D4-...

Capabilities                                                                    
Maximum Link Speed:                                                             100 Mbps
Transmit Buffer Size:                                                           96896 Bytes
Receive Buffer Size:                                                            775168 Bytes
Hardware ID:                                                                    PCI\VEN_10EC&DEV_8169&SUBSYS_816910EC&REV_10

Driver Information                                                              
Driver Manufacturer:                                                            Realtek
Driver Description:                                                             Realtek PCI GBE Family Controller
Driver Provider:                                                                Realtek
Driver Version:                                                                 7.114.1003.2017
Driver Date:                                                                    03-Oct-2017
DeviceInstanceId                                                                PCI\VEN_10EC&DEV_8169&SUBSYS_816910EC&REV_10\4&6B965E5&0&08F0

The OnBoard card shows a max link speed of 100 Mbps = correct so it only has max 100 Mbps but the TP-LINK card shows also 100 Mbps but should be 1000 Mbps here or?In the card options for this card I have the choice to set the speed to 1 GB fullduplex what I also did.Not sure why it does just show 100 Mbps for this card too now.

I have another short cable which was send with my router I could test on my PC but for this I have to move my PC into other room (maybe I try this in next days) just to be sure that this cable does work to get 1 GB but if not then the cable is not the problem.

One more question about the cable.So why does it work to get a connection to my router with the TP-LINK card (also if I just get 100 Mbps only) without problems and with my other card and the labtop I get it not?Thats one thing I dont understand yet.

PS: My 2 not working cards using chipset "RealTek RTL8169SC" so thats the info I found on small manual paper inside of the box.

greetz

Share this post


Link to post
Share on other sites
Kurapica

diagnosing hardware problems is not easy or fun and sometimes when you find a solution you

can never understand how it worked ! :D

anyway try to focus on common reasons for such problems.

1 - Check that you have a compatible driver, sometimes even the latest version can bring troubles.

2 - Check your cables for any cuts, make sure the insulation is good to reduce the interference.

3 - some hardware provide options to reduce energy consumption which leads to reducing speed

for example some Ethernet cards reduce speed to 100M to save power, you can check this for your card

in the device manager.

 

 

2017-12-28_114616.jpg

  • Like 1

Share this post


Link to post
Share on other sites
roocoon

In addition to the previous suggestions...

1) What about the router? Which model is it? It came from the ISP or off the market?

Usually its ports should auto-negotiate to the highest supported speed (the 100/1000 problem). Check its specs and try different ports.It could also be misbehaving and keep dropping the connection (like mine does sometimes).

2) The CAT cable. Try and borrow a CAT-7. Better insulation and support for higher speeds.

3) The computer itself. Does it support 1000Mpbs?

According to this page, you'd need IEEE 802.3ab support:

http://www.realtek.com.tw/products/productsView.aspx?Langid=1&PFid=4&Level=5&Conn=4&ProdID=10

Check out your computer's support as shown near the end of this page:

https://technet.microsoft.com/en-us/library/dd379826(v=ws.10).aspx

Good luck.

 

Edited by roocoon (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites
CodeExplorer

My Wireless network adapter:
TP-LINK 300Mbps Wireless N Adapter

On my (UTP) cable connetion: 1GBps!
Yeah it should be 1GBps!
 

  • Like 1

Share this post


Link to post
Share on other sites
LCF-AT

Hi again,

so I have test already diffrent drivers from my CD from the card I got till latest driver from internet 3/Okt/2017.Also this latest driver I did use before where all was working.The option Auto Disable Gigabit is set on disabled by default.The cable is ok so far so I dont see any issues or cuts etc but its also strange that I dont get a connection with this cable with the laptop too but I get connection with same cable with my OnBoard card & my TP LINK card.That strange.Some are working some not so that one point I dont really can understand.

The router (connect box) I got from ISP.I have test all 4 ports and get same results.If I connect the labtop on any of the 4 ports I get 1 GB to see on labtop status box of connection so there its working.

My cable is cat 6 and should be also enough so far but if I should order a new cable next time then I could order a cat 7 cable.

Where can I see whether my PC does support 1000 Mbit/s?My mainboard is this one....

BIOSTAR Group G41D3+
Product Version: 6.0
http://www.biostar.com.tw/app/en/mb/introduction.php?S_ID=513

If I check that CMD command netsh lan show profile then it says "The Wired Network Auto-Configuration Service (dot3svc) is not running".If I start this service then the CMD command does work and shows me this info...

C:\Windows\system32>netsh lan show profile

Profil auf der Schnittstelle LAN-Verbindung 3
=======================================================================
Übernommen: Benutzerprofil

    Profilversion          : 1
    Typ                    : Verkabeltes LAN
    Auto.-konfig.-version  : 1
    802.1X                 : Aktiviert
    802.1X                : nicht erzwungen
    EAP-Typ                : Microsoft: Geschütztes EAP (PEAP)
    802.1X Anmeldeinformationen zur Auth. : [Die Profilanmeldeinformationen sind ungültig.]
    Benutzerinformationen zwischenspeichern : [Ja]

Profile datas are not valid!?Does it mean something series?

So what can I try next?Maybe something was changed in regedit?Not sure about that,so I wanted to try a other OS XP which I had on other HDD but it dosent load anymore from bootmenu (need to install again) just for testing what I get on XP.I also did reset the BIOS settings to optimal / default but also without any success.Just can try to make that CMOS jumper change for a minute & or plug in / out the battery.

greetz

Share this post


Link to post
Share on other sites
LCF-AT

Hi guys,

today I moved my PC into next room to check it with other & old cables and they are working and I get 1 GB to see!!!! :) I also checked my GBE card and this is working too with the other old cables.This is really unbeliveable.All the problems just made by my half year old cat 6 cable.The other cables I did test are stone old and one of them I did used before but in those days I didnt got full speed with that cable & GBE card (thats the reason I did buy a newer and higher cat 6 cable) and today it does work in the other room!?I really dont know where the problem could be.Maybe something does disturb the cable that it makes trouble but what?Cable just laying on the ground under 2 heaters in both rooms.Also its laying on the same way as a TV cable too (both going to same whole in the wall to next room).Not sure whether this could be a problem etc. :( Also I dont know whether it makes sense to buy a new cable.I think I will move the old cable back (20m long) next year and do test it first.Maybe it does work and maybe just for a while or some months only.

PS: Maybe its really any kind of diffrent room temperature what makes trouble but I also thought that the cable having a good shielding for that too.Has anyone of you some ideas what kind of cable I could use / buy them to prevent such problems?

greetz

Share this post


Link to post
Share on other sites
Kurapica

My guess was right :D

I blame China ! always buy a high quality brand and keep them away from heat and strong electromagnetic fields.

 

  • Like 1

Share this post


Link to post
Share on other sites
LCF-AT

Hi,

so did I buy such a bad cable product?

Problem is I cant keep the cable away from the 2 heaters where the cable are laying under in both rooms. :( The distance from ground up to heater bottom are 10 cm free space between so this should be ok I think.In the rooms are also no audio boxes which could disturb.

About the cable.I have no plan which are good or bad.Only know that I should pick a cat 5 or higher cat cable.Do you know some good cable brands or cables I need for my conditions?Maybe you have any hints about that.

greetz

Share this post


Link to post
Share on other sites
Kurapica

I can't recommend any thing but make sure you buy something not made in China, I'm sure you can find some good stuff in Germany.

 

  • Like 1

Share this post


Link to post
Share on other sites
CodeExplorer
On 12/29/2017 at 5:55 PM, Kurapica said:

I can't recommend any thing but make sure you buy something not made in China, I'm sure you can find some good stuff in Germany.

Is there anything which isn't made in China??? As far as I know all product are actually made in China!
 

  • Like 1

Share this post


Link to post
Share on other sites
Kurapica
23 hours ago, CodeCracker said:

Is there anything which isn't made in China??? As far as I know all product are actually made in China!
 

I'm afraid you are right :D

 

BcM6--PCEAALedb.jpg

  • Like 1
  • Haha 2

Share this post


Link to post
Share on other sites
evlncrn8

electric heaters ?...

  • Like 1

Share this post


Link to post
Share on other sites
LCF-AT

Hi again,

the heaters using heating oil.No electric.I check the internet for some diffrent shield cable protections and found much diffrents with the whole cable short cuts.So my cable seems only to have a foil shield (F/UTP) and others having more shields.So at the end I think I need to order any S/STP or F/STP cable what has a better shield but its also more stiff.I think I will order one of these cable soon and will see whether it will work then.

greetz

Share this post


Link to post
Share on other sites
antrobs

Hello LCF-AT! I encountered a cable problem too a year ago on and off connection, speed not sticking to 1GB and it turns out the RJ-45 pins are corroded then a little bit of cleaning it works good again... But yet a better cable for types of environment is best for preventing electrical interference and etc.

Share this post


Link to post
Share on other sites
evlncrn8

time to dig out the wd-40 then 

Share this post


Link to post
Share on other sites
NOP
On 1/8/2018 at 3:08 AM, evlncrn8 said:

time to dig out the wd-40 then 

wd40 is oil based and should not be used on contacts. it will leave a conductive film across the contacts unless cleaned properly

it is far better to clean with switch cleaner or acetone which cleans then evaporates after a few seconds :D

Share this post


Link to post
Share on other sites
LCF-AT

Hi guys,

short update.I got a new cable now. :) No noname cable cat 7 S/FTP PIMF.This one is more softer (no clue why so I thought it would be more stiff) than my F/UTP cable I used before.After connecting the new one I got again 1 GB/s and full-speed back and my NWork diagnosis shows everything is alright (all green / no red entrys anymore).One problem less and I hope that this problem is history now or maybe in few months I get same trouble again but then I will eat a broom (or put it somewhere into someone). :)

greetz

Share this post


Link to post
Share on other sites
Kurapica

Glad to know it's solved :D

Share this post


Link to post
Share on other sites
Techlord

I've had my share of troubles with system configs that apparently look perfectly ok but with weird connectivity problems - all these finally traced to a faulty network cable that'd gotten bad over the years mainly due to repeated kinking. Apparently, repeated kinking weakens some strands in the cable, leading to faulty connections that are not even faulty consistently but only show errors when the cable gets bent in exactly that same position sort of a thing.

So one of the first things that I do nowadays is to simply swap out the cable and try with a known good one from another system. Just takes a minute to try it out but saves a ton of time which would have otherwise have been wasted debugging.

Anyway its good that the problem is now solved :)

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×