Jump to content
Tuts 4 You

Firefox problem with flash and none SSL sites


LCF-AT

Recommended Posts

Hi guys,

so I found another new problem using FF (latest version) and flash plugin.So I visit a site using just http connection and on this site there are many mouseover flash windows to see preview video if you go with mouse over any small image there.Now the problem is I dont get any preview to see and also get a message to activate the flash plugin but its activated already.Now I tried to visit same site with Chrome & IE and there is everything working.

I checked then the browserbar of FF (icons on left site before address) and there I see flash is active on that site and the other icon tells me the connection is not secure etc but there I cant disable something.If I got for example on the...

https://www.adobe.com/de/software/flash/about/

...site then it tells me same but there I can disable the secure mode and then I also get the flash animation to see after.If I visit same site just with http then there is not option to disable the mode.

So all in all I think there is any problem with that none SSL + flash and I dont know how to allow the site using flash plugin if the site only used http.First I thought its any other issue like activeX dosent work correctly or something and tried to update this one and also tried to run FF clean also without addons etc but nothing was working.

Next I found a another same site of the site I try to get working with flash and this site used SSL connection and there is also everything working.Both sites looking almost same just using other layouts etc what brings me to the thought that the problem is that none SSL connection issue.

Also on that http site it does switch to html 5 and dosent use flash and kicks it out.

So what can I do now to allow http sites using the flash plugin?I dont wanna always change using the browser just because and site using http only.Maybe you know how to handle / allow this in FF.

Thank you

Link to comment

Hi,

I told already that flash is active.Problem must be the none SSL connection & flash thing which seems to get disabled or not allowed etc and does switch to html5.Chrome & IE are working as it should but FF makes trouble.Maybe its a configuration issue of that site or whatever.

greetz

Link to comment

Hi again,

so the problem is found now so thats the good news. :)

The problem why it wasnt working was that I used a disabled ProtectedMode (set to 0) in the mms.cfg file of Macromed\Flash folder.I changed it back to enabled (1) and now oh wonder its working for that site.But its still a mystery why I need to enable this option to get it work with that one site.Other sites had also no problems with a disabled ProtectedMode.Also Chrome & IE had no problems with disabled ProtectedMode and only Firefox did make problems.Strange strange.

So in the flash plugin options of Firefox there is also a function called protection mode you can disable / enable but this has no effect and seems not to be same as I said above.

greetz

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...