Jump to content
Tuts 4 You
Sign in to follow this  
LCF-AT

T4Y - Performance test is very bad for me...

Recommended Posts

LCF-AT

Hi guys,so since a whole while I have some speed & performance trouble with our tuts4you homepage only and I am no internet expert and tried to find any test homepage to check the performance and to get some visual results.Now I found a page and have make two test and wanna show you my results in pictures so that you can see the differents which are very large.But all in all I still don't know what I could do to fix that problems you know etc.Now just have a look on my pictures.I made a test on pagespeed.de
2nszyt.png
2zgsras.png
28byvxc.png
ogb97t.pngNow you can see my download speed on T4Y today which is really a joke...
1zba2cx.pngOk now I make the same test with google....
2i3o86.png
t8qjk6.png
143htuu.png
2uqn4hh.pngSo what should I say now....you see I got perfect results for google (97 Points of 100) and ultra bad results for T4Y (5 points of 100) but why?Where is the problem and how to fix this?The download speed sucks and to surf on T4Y is also very slow and the most time I have just to wait here so this makes not much fun etc.I just wanna know whether some of you have the same trouble with T4Y only or not but of course it would be better to find any helpfully solution to increase the T4Y performance & speed again like it was earlier.So what can I do if the problem is on my side or what could Ted do or can we do nothing?Maybe anybody of you has a answer for this question.Thank you

Share this post


Link to post
kao

I see exactly the same results in that test - but have no problems using T4Y whatsoever. I'm guessing that this test is really badly designed and shouldn't be used as a benchmark for anything:

jzjFAFv.png

My download speed from T4Y is not that great, but it certainly isn't as bad as yours:

Xc7YYTE.png

As for the speed issues - I would start by making sure my PC is malware-free. Then I'd clean up my browser cache, cookies, all that stuff - or just try a different browser. Then use 'ping' and 'traceroute' to make sure it's not a problem with my ISP or something. After that I'd be really confused.

Maybe Teddy can look up his server logs and see why you're having problems with the server, but I doubt he will see much in them..

Share this post


Link to post
LCF-AT

Hi koa and thank you for testing too.Sounds really strange that you got the same results as me.So I thought others would maybe get also other and better results as me.So I see you have a lot more better download speed as me.I tried today to download the same file here a few times on different times and the highest DL rate I got was 50 kB/s and the lowest was 6 KB/s. :( Bud as I said I have only on T4Y that problems.


 


Ok I tried to scan for maleware but there was nothing found = clean at the moment.Browser cache get cleaned each time if I close FF and I also use CCleaner too.I also tried IE but there I got also the same = no changes.I also tried in the past to check T4Y with tracert CMD but there was nothing bad to found like a friend told me after checking the results of it.


 


Also ping test seems to be ok right?



Ping tuts4you.com [198.57.187.53] mit 32 Bytes Daten: Antwort von 198.57.187.53: Bytes=32 Zeit=172ms TTL=43
Antwort von 198.57.187.53: Bytes=32 Zeit=172ms TTL=43
Antwort von 198.57.187.53: Bytes=32 Zeit=172ms TTL=43
Antwort von 198.57.187.53: Bytes=32 Zeit=172ms TTL=43 Ping-Statistik für 198.57.187.53:
Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0 (0% Verlust),
Ca. Zeitangaben in Millisek.:
Minimum = 172ms, Maximum = 172ms, Mittelwert = 172ms

So if I try to use ping with a paramter -t at the end "www.tuts4you.com -t" then it will run endless but for other pages too = more than 30 minutes and after this I closed CMD manually to exit this checking with -t parameter.


 


No idea what the problem is but its really a pain in the butt to have this problem only here you know and thats a little big O strange.Is there no simple tool which I could use which makes any tests and tells me after "Oh-ha...Problem XY Found please do this and that to slove the problem" etc you know something like this maybe for dummies. :)


 


greetz


Share this post


Link to post
NikolayD

Think problem in https.


Share this post


Link to post
Dreamer

also problem can be if you use proxy or programs like hideip they will slow down connection every time  i use hide ip connection going extreme slow.


Share this post


Link to post
kao

@LCF-AT: I have pretty much the same results in ping, too. :)

Pinging forum.tuts4you.com [198.57.187.53] with 32 bytes of data:Reply from 198.57.187.53: bytes=32 time=172ms TTL=47Reply from 198.57.187.53: bytes=32 time=174ms TTL=47Reply from 198.57.187.53: bytes=32 time=172ms TTL=47Reply from 198.57.187.53: bytes=32 time=172ms TTL=47
So, that's probably not the problem.

I found a nice server (webpagetest.org) that allows to test page load issues from different browsers and different locations - but I cannot find any tests that can detect what's wrong with your connection or your PC. :(

* Chrome from Germany works fine: http://www.webpagetest.org/result/140228_FY_B1T/

* IE9 seems to have some problems. http://www.webpagetest.org/result/140228_KA_B3H/

* Firefox seems to be OK: http://www.webpagetest.org/result/140228_NJ_B56/

I would try using a proper VPN - if problems persist, it's your PC issue (browser/firewall/antivirus/etc.). If problems disappear, it's your network connection issue (your provider doesn't like tuts4you, or vice versa). For example, you could try VPNGate (http://www.vpngate.net/en/) which is free academic project, but there are dozens more.

Share this post


Link to post
Teddy Rogers

We could discuss this over and over but as I have mentioned on numerous occasions there is nothing wrong with the server. I'm much further away geographically than you and I have no problem with speed. If there was I problem I'd be the first person tackling it. Whilst knowing all this doesn't help your cause I'd suggest checking your computer, modem/router settings and maybe even giving a call to your ISP to see if they can help out...


 


Ted.


  • Like 1

Share this post


Link to post
LCF-AT

Hi again,


 


https = problem?Hhmmm maybe you are right so I think before T4Y did use http and there I had no such big trouble but I am also not sure whether I do remember right about that.So does it mean that I should then have trouble with each other https pages too?But google used also https and there I have no problems.


 


No I don't use any proxys or hide IP tools etc.


 


Yes this webpagetest I found and did test too yesterday and your results seems to look like my too just that I had 8.x seconds loading time on the first access.


 


"your provider doesn't like tuts4you" - What! :) Why that?Or is it just any server issue = where the server is home = country xy?If yes can I see that somewhere in any list etc?


 


So about this VPN things so I installed and tried it now with any connection from UK and then I tried to download from this forum and its much fatser now as before with my access......!?!



My Normal Internet Access = 16 KB/s download
UK Access = = 120 KB/s download
Other German Access = 200+ KB/s download
Hungary = 300+ KB/s download

So what is that for a dirt?I can download a lot faster with any other access than my own on T4Y!Who is guilty now on that stupid problem?Its really my provider now?So the problem seems not to be on my computer or any settings on my computer right?What now?Have I to live with that problems now and T4Y?


 


Ok thanks again so far also for the tool hint of VPN so now I have the chance to download files from T4Y with almost normal speed if I use VPN. :) Not the best solution but already better than nothing and better as to download with a speed of 16 KB/s only!


 


So what should I do Ted?Calling my provider and asking why they have a problem with your server location US / Utah / Provo and ISP Unified Layer?


 


greetz


 


Share this post


Link to post
Teddy Rogers

You were complaining of bad speeds long before the changeover to https. After the change over to https you even commented on a speed increase for a little while then, unfortunately, your speeds dropped off again.


 


My sphere of influence only spans as far as the server. I have no control over how traffic is managed over the internet to you. All I can do is to let you know that there is nothing wrong with the server and its connection and that I can only advise you in various courses of action which may help locate and even remedy the problem... :dunno:


 


Ted.


  • Like 1

Share this post


Link to post
LCF-AT

Ah ok so I did not really remember whether I had this speed problems already before you did switch to https.Sorry.So the problem is really mostly the download speed so it can not be that I only get a speed of 6 - 30 KB/s right.Ok Ted so if the problem is not on your side then I need to find the possible reason why I have this problems only on T4Y of course also if I have almost 0 ideas what the problem could be you know.So the only thing what I could try is to test my internet with a other PC / Laptop maybe to see whether there I get the same trouble or not but I think there I should get the same trouble.Ok anyway so I will try to test it in the next days and send later a feedback.


 


Thanks again for all and sorry for asking and to have 0 plan about these stuff.


 


greetz


Share this post


Link to post
kao

Yes, such problems really exist. For example, my home connection has problems opening Black Storm Forum and one foreign news portal - it just times out frequently. Nobody knows why, and ISP is too big to care for such small issues. :( I learned to live with it.

+1 for trying to get another PC and making sure it's really the issue with your connection, not PC.

Calling ISP support phone is generally pointless, they tend to have guidebooks with X simple steps after which they say "our connection is fine, it's a problem on that server side, talk to them". On the other hand, if you can get ISP technician to visit your house, he might be able to actually help. But I wouldn't bet on it. :)

Share this post


Link to post
GIV

Here is what i got:



Pinging tuts4you.com with 32 bytes of data: Reply from 198.57.187.53: bytes=32 time=185ms TTL=45
Reply from 198.57.187.53: bytes=32 time=186ms TTL=44
Reply from 198.57.187.53: bytes=32 time=185ms TTL=45
Reply from 198.57.187.53: bytes=32 time=185ms TTL=45 Ping statistics for 198.57.187.53:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 185ms, Maximum = 186ms, Average = 185ms

Share this post


Link to post
LCF-AT

Hi again,


 


ok today I have test to download the same file from tuts4you on both computers.First on my PC = download 40 KB/s and getting slower during download and then I tried on a Laptop via Wlan to my router = same bad results.Both tests I did in the same minute.So now I can already say that its no PC problem in my case.


 


Ok so it seems really to be a ISP issue and I also think that I have to live with that problems now like you too kao. :(


 


greetz


Share this post


Link to post
nonspin

The ping doesn't tell you anything but how fast the remote server responds to single request.


You should run a tracert on the site to actually check if you are diverted through proxies or vpn's.


It also tells you about possible bottlenecks.


 


cmd > tracert www.tuts4you.com

Share this post


Link to post
LCF-AT

Hi nonspin


 


I tried already different CMD commands but I see no problems so far if I see it right.Only different I see are the times if I try the same with tut4you and google so for google the ms times of all are under 100 ms and for T4Y are max 202 ms and the half of all 13 connections have more than 100 ms...



Routenverfolgung zu tuts4you.com [198.57.187.53]
über maximal 30 Abschnitte: 1 1 ms <1 ms <1 ms Home
2 22 ms 25 ms 22 ms <--- Germany
3 21 ms 21 ms 20 ms ...
4 21 ms 20 ms 21 ms ...
5 44 ms 46 ms 45 ms ...
6 50 ms 50 ms 49 ms <--- United Kingdom London
7 111 ms 111 ms 111 ms <--- US California
8 128 ms 135 ms 128 ms <--- US California
9 178 ms 178 ms 189 ms <--- US California
10 194 ms 195 ms 199 ms <--- US California
11 * 168 ms * <--- US California
12 169 ms 168 ms 169 ms <--- US Utah unifiedlayer.com
13 170 ms 169 ms 169 ms tut.tuts4you.com [198.57.187.53]


Routenverfolgung zu google.de [173.194.113.159]
über maximal 30 Abschnitte: 1 <1 ms <1 ms <1 ms Home
2 21 ms 21 ms 21 ms
3 20 ms 20 ms 20 ms
4 20 ms 20 ms 21 ms
5 21 ms 21 ms 22 ms
6 26 ms 27 ms 25 ms
7 31 ms 29 ms 31 ms
8 42 ms 63 ms 42 ms
9 43 ms 42 ms 42 ms
10 40 ms 40 ms 41 ms
11 40 ms 39 ms 40 ms
12 41 ms 41 ms 41 ms
13 40 ms 41 ms 41 ms ham02s11-in-f31.1e100.net [173.194.113.159]


pathping www.tuts4you.com
----------------------------------------------------
Berechnung der Statistiken dauert ca. 325 Sekunden...
Quelle zum Abs. Knoten/Verbindung
Abs. Zeit Verl./Ges.= % Verl./Ges.= % Adresse
0 localdomain
0/ 100 = 0% |
1 0ms 0/ 100 = 0% 0/ 100 = 0% Home
0/ 100 = 0% |
2 20ms 0/ 100 = 0% 0/ 100 = 0% Germany
0/ 100 = 0% |
3 22ms 0/ 100 = 0% 0/ 100 = 0% Germany
0/ 100 = 0% |
4 20ms 0/ 100 = 0% 0/ 100 = 0% Germany
0/ 100 = 0% |
5 48ms 0/ 100 = 0% 0/ 100 = 0% Germany
0/ 100 = 0% |
6 50ms 0/ 100 = 0% 0/ 100 = 0% United Kingdom London
0/ 100 = 0% |
7 115ms 0/ 100 = 0% 0/ 100 = 0% US California
0/ 100 = 0% |
8 132ms 0/ 100 = 0% 0/ 100 = 0% US California
0/ 100 = 0% |
9 184ms 0/ 100 = 0% 0/ 100 = 0% US California
0/ 100 = 0% |
10 203ms 0/ 100 = 0% 0/ 100 = 0% US California
21/ 100 = 21% |
11 --- 100/ 100 =100% 79/ 100 = 79% US California
0/ 100 = 0% |
12 --- 100/ 100 =100% 79/ 100 = 79% US Utah unifiedlayer.com
0/ 100 = 0% |
13 169ms 21/ 100 = 21% 0/ 100 = 0% tut.tuts4you.com [198.57.187.53]

And now?Do you see any bottlenecks?


 


greetz


Share this post


Link to post
Teddy Rogers

Doing a ping comparison between Tuts 4 You and Google is a bit moot. Google is a multi-billion dollar company with data centers and servers located in every corner of the globe. Tuts 4 You has one server located in a data center in the US. Hardly a comparison... :dunno:


 


Ted.


Share this post


Link to post
LCF-AT

Hi Ted,


 


of course you're right with your statement. :)


So I just wondering why I have these trouble.....


 


Exsample: So now its 7:46 h in the morning and now I have a good access speed on tuts4you so that I can also surf normaly now and the pages which I try to open gets open quicker.Also the download now has a speed of 240 KB/s and not as before 40 KB/s or lower with 6 KB/s etc you remember.



38 users are online (in the past 15 minutes)
10 members, 25 guests, 3 anonymous users

So the performance is in this moment ok (no idea why its better now) but I think later it will be getting again worse.So the problem can't be the user traffic on T4Y so you remember I tried to download before with my normal internet connection = 16 KB/s and direct after almost one minute with the VPN IC of Hungary which gave me a download of 300+ KB of the same file.


 


Mostly the problem is that I have to wait a longer time till a page of T4Y will loaded (almost any page I call so in the worst case till max 30 seconds) and now for exsample I would like to clean my PM Box which is already full again and want to check which PMs I can delete and which not etc and for this I need to call each PM page and if its need a long time then I also have no fun to check the PMs quickly which I can delete and which not etc you kow.


 


So all in all I believe you of course that the problem is not on your side so maybe its any unknown ghost issue :) or whatever no idea.I could make a video where you can see how long T4Y works etc but this would also not fix the problem so there you could just see that T4Y is working slow for me and other pages as youtube etc not. :)


 


Anyway so I think there is no solution in sight for me.


 


Idea: So do you know any other homepage which using the same server as T4Y?If yes then tell me so then I could check these too to see whether they are also so slow or not or?Or maybe you could create any test homepage on your server next to T4Y and there you upload any file which has 5 MB for exsample and then you send me the address of this test page via PM and then I try to download the testfile from there to check whether its also so slow.No idea whether it would bring something or not etc.What do you say?


 


greetz


Share this post


Link to post
LCF-AT

Thanks for the info Ted but I see that Tor is more for some people who wanna surf anonymous and also I shouldn't use AddOn etc if I use it.


 


Ok listen so now I made again a another test with VPN and used a Korea connection this time and tried to download something from T4Y and with this connection I got a download speed of 980 KB/s. :) After this I disconnected the pipe again and download with my connection = again only max 40 KB/s.



Routenverfolgung zu tuts4you.com [198.57.187.53] über maximal 30 Abschnitte: 1 312 ms 311 ms 310 ms 10.211.254.254 VPN
2 312 ms 310 ms 311 ms 192.168.0.1
3 316 ms 316 ms 314 ms 14.38.29.254 Korea
4 311 ms 311 ms 311 ms 121.129.191.165 Korea
5 319 ms 311 ms 313 ms 112.188.28.5 Korea
6 312 ms 312 ms 312 ms 112.188.17.29 Korea
7 317 ms 318 ms 323 ms 112.174.59.113 Korea
8 314 ms 316 ms 338 ms 112.174.48.70 Korea
9 312 ms 312 ms 351 ms 112.174.84.98 Korea
10 517 ms 446 ms 449 ms 112.174.97.242 Korea
11 458 ms 453 ms 457 ms 198.32.176.13 US California
12 465 ms 456 ms 464 ms 69.22.142.0 US Chicago
13 479 ms 461 ms 472 ms 69.31.64.6 US Virginia
14 458 ms 469 ms 515 ms 69.27.175.163 US Utah
15 461 ms 470 ms 459 ms tut.tuts4you.com US Utah

greetz


Share this post


Link to post
nonspin

just to get something obvious out of the way:

Did you somehow disable your cache ? I mean, the graphics should load somewhat faster the second time you access them.A lot of so called "internet speed optimizers" nowaday tend to mess up the speed rather than doing anything good. So - to be on the safe side - check your settings with TCP Optimizer (free). If you need

help finding the correct settings,  contact me.

 

http://www.speedguide.net/downloads.php
 

ps: i dont have any issues accessing t4y - but then again the speed is kinda different =/

Edited by nonspin (see edit history)

Share this post


Link to post
LCF-AT

Hi,


 


ok I have test your tool (thanks for the hint) and did apply the optimized option + modify all adapters etc like I have seen in some video tutorials + tool description and did reboot but it has no effect for me.T4Y is still same slow as before and download has only 13 KB/s today (other sites I have 1.2 MB/s) and to load any site on T4Y takes today again a ultra long time.So I also think now that this is only a provider problem so that they reduce some connections to somewhere to certain times.Also my provider has just a mediocre and lower assessment in the ranking of all providers.


 


So it seems that T4Y + my provider keeps a red cloth for me. :( Its already funny that of all internet sites exactly only this T4Y is affected and not any other site.Maybe just a ultra random or? :)


 


greetz


Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×
×
  • Create New...