Jump to content
Tuts 4 You
Sign in to follow this  
LCF-AT

VirtualBox Problems

Recommended Posts

LCF-AT

Hello,

so yesterday I installed VirtualBox-4.1.6-74713-Win.exe on my system after a long time again. :) Also installed win2000 SP4 and also the VirtualBox Guest Additions which was to find in the VBox folder.All seems to be fine but then after some tests I got this problems.

- HWBPs does not work in Olly

- Scrolling in Olly hangs and is very slow | if I try to move the dump window higher or lower then its really nasty

- Olly can't read some Olly plugins

Ok I have seen that the HWBP problem was already fixed in a older VBox version but now I have the problem in this new version.The question now is whether this version is the problem or something else!?!

Now the plugins.So I just want to use the ODBGScript plugin with Olly and I have test both from the package ODBGScript.dll <-- does not work and then the ODbgScript_Win2k.dll which should work with win2000 but surprise Olly does not accept this plugin too in the plugin menu!Then I found a older a ODbgScript_Win2k.dll version which Olly has accept [no idea why] but if I open the script window then I see a yellow exclamation mark on the window left above.Also this script is a older version and does not support all commands.So normaly I want to use a latest script version 1.82.6 | 1.83 + but they don't work!

So what can I do now?So if you know a solution how to fix these problems [need HWBPs + new Script solution] then tell me please.So I can't remember what I had done the last time where I had used VBox before a few years.I hope that you have some hints for me.So I don't belive that the VBox maker have forgotten to add the HWBP bug in this new version but I don't know it.

Thanks

  • Like 1

Share this post


Link to post
NullPointerException

I had the same problem with hardware bp in virtualbox in the past with a different version.

I have never solved it even after upgrading to newer versions altough some people claims that it worked for them.

My opinion is that it's a matter of hardware. Are you running virtual box in a old pc?

Hate to say but sometimes free software is not the best especially for re tasks, consider to switch to vmware. i can assure you that with the old workstation 6.5 i had never a problem with hwbp or virtualkd.

Share this post


Link to post
LCF-AT

Hi NullPointerException,

uhhmm this sound very BAD! :) So I have seen that the HWBP issue was fixed since version 2.x in a changelog and now you tell me this bad news.Hhhmmm.So I also installed a 2. vdi with Windows XP to check whether the HWBPs are working on this OS but also the same on XP,no HWBPs are working.Great,big installing of all stuff + a lot time waste and now this!So I can really hope that someone has maybe a solution for this HWBP problem in VBox if not then I can throw all into the trash again.

So about VMWare.I tried this also in the past [1 time VM] but this app is very large [if I remember right] and works also slower on my system than VBox [if I remember right again] or it was other way around [if I remember right this time]. :) So I see that VBox eat a lot system resources and switching of all panels [all open app etc] of all [main OS & VBox itself] takes a lot time and hangs in the bad case for 30 sec and more and this is also a bad thing = my system is too low to handle them all at the same time.

Ah ok and thanks so far for the info N:P:E so I will wait a while and see what the other members have to tell about this problem.Maybe someone brings the light for me.

PS: Yes I use a older PC.P-III with under 1 Ghz.

greetz

  • Like 1

Share this post


Link to post
Nacho_dj

Hey mate, please read this ticket log about this bug, here you should find the answer:

https://www.virtualbox.org/ticket/477#comment:36

I hope you will get now HBPX working...

Cheers

Nacho_dj

  • Like 1

Share this post


Link to post
NullPointerException
PS: Yes I use a older PC.P-III with under 1 Ghz.

Then it's an hardware virtualization problem. Pheraps your processor is not properly supported by virtualbox ie virtualbox cannot access some features in you cpu. are you sure that hw bp worked for you in the same pc with older versions of virtualbox? Again, a commercial app like vmware might take care of a wider family of cpu.

i have your same problem with low resources but i can handle 1 vm running with xp in a old vmware. Not sure what you want to achieve.

  • Like 1

Share this post


Link to post
LCF-AT

@ Nacho_dj

Hhmm so do you mean I should try to install version 3.2.12?

Or

"Enable hardware virtualization, hardware breakpoints in OllyDbg? now work." =?Is there a option in Olly to enable this?I only can see this in Olly to set...

Debug:

"Use hardware breakpoints to step or trace code"

@ NullPointerException

Thats the problem so I can't remember whether the HWBPs was working for me with the older version before a few years.So I think yes but I don't know it anymore for 100% you know.Ok if you have also a low PC and your VM works normaly then it was maybe so that VMWare was faster than VBox with the main handling.

greetz

  • Like 1

Share this post


Link to post
GaBoR

I've tested on an Athlon II X2 245 running Windows 7 Pro 32bit, Windows 2000 VM, if I disable AMD-V, hwbp's don't work anymore.

I think your processor doesn't support hardware virtualization such as Intel VT-x or AMD-V, if it supports any of them then you should be

able to enable it in VirtualBox, select your VM, go to Settings->System->Acceleration & see there if there's available.

I think you need to upgrade, but you've probably heard that before smile.png . I had to use a Pentium II until 2006, when I upgraded.

Edited by GaBoR (see edit history)
  • Like 1

Share this post


Link to post
LCF-AT

@ GaBoR

VirtualBox, select your VM, go to Settings->System->Acceleration = GHOST :) Your are right so its disables for me.Cant choose this register card.Sh...t!

So must I swtich now to VMWare yes?Is it also sure that this tool supports HWBPs also on my low system?Just need to know this now for 100% before installing all this stuff again you know. :)

greetz

Share this post


Link to post
Nacho_dj

LCF-AT, if you are running an XP OS, you can install Virtual PC or vmware. Both of them will allow HWBP on your machine.

I use all of the three VM, and I can confirm this.

Cheers

Nacho_dj

  • Like 1

Share this post


Link to post
LCF-AT

@ Nacho_dj

Ok Virtual PC or VMWare + XP.Thanks for the info.So at the moment I have enough of VBox.So I will test now Virtual PC so I see it has also just a size of 30+ MB and VMWare more than 500 MB!So I hope that Virtual PC also supports the OS vdi file of VBox if not then I have to install the OS again.I will see and report then the news after installing & testing.

greetz

Share this post


Link to post
GaBoR

You could try VMware Player too, the installer is 116 MB, installed occupies around 188MB, you can create new vm's, edit vm settings, etc:
/>http://www.softpedia.com/get/System/OS-Enhancements/VMware-Player.shtml

Share this post


Link to post
deepzero

for older hw i can really reccomend MS Virtual PC 2007.

Back when i used a pIII cpu, hwbps were working for me. (although it was a pretty good pIII).

Performance of the host system was OK, too.

I would also reccomend to use XP, not 2000. Much better support from all sides: rce tools, security updates,....

Right now i am running a XPSP3 system on VirtualPC on a p4 1,8 ghz machine....everyting works perfectly fine. smile.png

edit:

asides that, you should really upgrade. Is this just your reversing PC? (if so, why not install a VM on your main system?)

If that pIII > 1ghz is your main machine, check you local junkyard, with a little luck, you find better stuff there.

(this is where i got my pIII (~1,5 ghz) from, and that was some years ago...)

Edited by deepzero (see edit history)
  • Like 1

Share this post


Link to post
LCF-AT

Hi all,

@ GaBoR

Ok so is this player working like VMWare?Or can I use this player alone without other VM stuff etc?

@ deepzero

Yes upgrade is a good idea. :) No its my all in one PC.Just use this one.I call it the "time eater" :) Just eat my time with only waiting for everything.Spend more time with waiting than everything else.

ok now I installed Virtual PC 2007.What happend?

1. Crash durring installing!Anyway.

2. Installing XP SP 0 or 1 // No SP2 or SP3 - Need a lot time to install the OS so VBox has installed the OS very faster!Anyway.Also here crash on installing XP of my main OS again! = 2 times big crash!Anyway.

3. Load XP OS.Seems to fine and performance is also very faster and better than VBox.

4. Install additions VMAdditions.iso

5. Restart and now.....screen has a 4 bit colour sheme with the videodriver from the VMAdditions!=?Can not set it higher so there is nothing to choose!

6. Diable video driver and now it loads without video but now I can choose all 32 bit & 1024x ... and more!?!

7. Ok I let it so and test Olly now.Copy my Olly in shared folder and copy Olly to new OS.Setup ini paths and start.What happend?Yeah another crash = strongOD driver trash.Ok now I use clean Olly + strongOD with kernelmode.Now Olly starts but no driver was loaded!Hmmmmmmm!!!MMMHHHMMmmm!So ne sch.... hier!Ok now I test Olly + TM app & notepad too.I trace over command = app terminated!What is this?

Push xxxxx = Olly Terminated

Pushad = Terminated

sub esp, -4 = Terminated

Ooohhhhhh!

Ok,restart the trash open Olly load notepad and run ahhhhh now it works. :) But then after a while and reloading any app I got the same trouble.So why does it just terminate if it wants to execute a simple command?

Other problem is that I can not change the VirtualPC window manually with mouse.So I can make it smaller but not higher and also a auto window snap / adjust is also not to see.So VBox had such feature.Ahh,hardware BPs are working in V-PC. :) This is the best message which I can tell you but the rest seems to make a lot trouble but I dont know why.

So can you tell me what I have done wrong and what I can do to fix this video driver,push terminate and crash problems?Need some infos.

Ah,is there also a way to increase the vhd file?So I have enter a size of 1.3 GB at the beginning and now its has a size of 1298777 KB already.

PS: Virtual Disk Precompactor.iso <--- Should I install this too?Ah and there is also a strange size showing in the explorer in the VM.So it shows me almost 12 GB of free size?!?Why this?Seems also be a error or something.

greetz

  • Like 1

Share this post


Link to post
Nacho_dj

A very good advantage of Virtual PC is it allows drag&drop from outside to the inside of the VM and viceversa...

I hope it will work fine for you. I use it on W2K as host, and in another machine with XP sp3 as host. Both of them go fine!

Good luck with your tests

Kind regards

Nacho_dj

Share this post


Link to post
GaBoR

Yes, it's working like VMWare. VMware Player is a stripped down Vmware Workstation.

From vmware site:

Do I need another VMware product to use VMware Player?

No. VMware Player enables you to create and run virtual machines. However, if you need to leverage powerful developer-centric features such as Teams, multiple Snapshots and Clones, or Virtual Rights Management features for end-point security, you will need to upgrade to VMware Workstation.

On softpedia site it says it requires :

· 64-bit x86 CPU

· LAHF/SAHF support in long mode

So your PIII is most likely not compatible.

I suggest buying this computer from ebay:
/>http://www.ebay.de/itm/AUFRUST-PC-Intel-G530-2x-2-4G-Intel-Grafx-4GB-DDR3-1333-/150690953263?pt=DE_Technik_Computer_Peripherieger%C3%A4te_PC_Systeme&hash=item2315e1782f

Or if you don't have that amount of money here are some cheaper alternatives:
/>http://www.ebay.de/itm/HP-DC5750-Athlon-64-X2-4800-2-5-GHz-1024-MB-80-GB-DVD-ROM-/190598556285?pt=DE_Technik_Computer_Peripherieger%C3%A4te_PC_Systeme&hash=item2c608f2a7d
/>http://www.ebay.de/itm/HP-dc5750-Athlon-64-X2-DualCore-4000-2-1GHz-1GB-80GB-/290630339103?pt=DE_Technik_Computer_Peripherieger%C3%A4te_PC_Systeme&hash=item43aaeb0a1f
/>http://www.ebay.de/itm/IBM-ThinkCentre-A60-9384-W87-AMD-Athlon-64-X2-3800-/260877467290?pt=DE_Technik_Computer_Peripherieger%C3%A4te_PC_Systeme&hash=item3cbd823e9a

Share this post


Link to post
deepzero

jesus, the prices went down sincei checked ebay the last time... O_O

Share this post


Link to post
LCF-AT

Hi again,

ok I will test your VMWPlayer now maybe this will work better than with V PC.Also I dont know why V PC makes this trouble so VBox was working good with the same XP OS + my Olly & StrongOD just HWBPs was not working and in V PC HWBPs are working but the rest not.

Thanks also for the links GaBoR so I see they dont cost too much. :) I will see but normaly I dont need a new PC.But will think about it.

greetz

Share this post


Link to post
deepzero

I will see but normaly I dont need a new PC

ah, for a long time i said this about my hopelessly overclocked amd k-5 cpu... :)

Back in the day when my GPU was faster than my CPU...

I then upgraded over a pIII to the 1,8 ghz p4 i have now and it was...awesome! totally worth the upgrade! Go for it! :)

Share this post


Link to post
LCF-AT

Hhmmm I can not install the VMWPlayer!

Great!I use XP SP3.

1 GHz or faster = no

1GB RAM minimum = no

150MB of disk space = yes

-----------------------------

What now?

greetz

post-27695-0-04303500-1321219809_thumb.p

Share this post


Link to post
Killboy
What now?

Get a new PC...

The minimum hardware specs are there for a reason. Your specs were OK back in 2000 or something.

I realize some can afford a faster PC and some can't or refuse to. Either way, there's not much else you can do.

Share this post


Link to post
Nacho_dj

I have just tested my machine with W2000 OS, and these are the characteristics:

PIII 1Ghz

512 Mb RAM

W2000 sp4

There I have installed Virtual PC 2004, containing XP sp3 and W98 second edition, and both run fine. I admit performance is a little slow, but normally it allows any reversing task.

LCF-AT, if you want I perform any test on this VM, just let me know.

Best regards

Nacho_dj

Share this post


Link to post
LCF-AT

Hi all,

so today I have download VMWare Player "VMware-player-3.0.0-197124.exe" in the hope that this will help me more than the other stuff which I had installed before.So I start installing and this time I get no CPU etc message like in version 4.0!So this older version works so far.Now it was installing 3.0 and after a while I get a message about Virtual PC SP1.....it must be uninstall it before contine VMWarePlayer installing!?!GREAT!I press OK lets uninstall VPC.....after a while......CRASH!GREAT!I reboot the trash.Install again.....now it works so far....after a while the blue bar is short before the end "two millimeter".....System hangs!Cant move the mouse anymore & buttons [light] too!What the f....!Ooohhhhhhh!!!Ok I must reboot the dump after waiting 15 minutes where nothing happend in this time.I see there are no icons created of VMWP anyway.I start VMWP and it starts,ok.Now I choose my old OS from Virtual PC and it takes a while but then it accept it and now I can start the OS.I am waiting a bit and then......unable to....kernel device bla bla vmx86 trash....whatever...did you reboot the system.....yes I did!Ok now I was sarching on the net and find tons of entrys with the same trouble. :) Totaly crazy!So a normal user is thinking now.....hmmmmhm....big trouble since a longer time so I think the VM company has made a fixing patch for this issue or?NO of course there is no fix to get which can fix this stupid problem!Now I get a thick neck of course.

Installing = Trash

Solutions = Trash

De-Installing = Totaly Trash

So what the hell is going on here?

I have seen some solutions how to fix this problem like to start the software panel and change/remove VMWP so that then comes a repair box but 1. there is no VNWP in the software list and also no uninstaller to find.So I had to uninstall it with a uninstaller forcing tool now so a reinstalling was not possible so it always detect the VMWP on the system.I have not reboot my PC now so I dont know whether the uninstall was successful or not so I will see it next day.

Result = Big "O" M.F. TRASH high 10

Maybe I have tomorrow more luck but I dont think so.I think I can forget to get the VM installed correctly for me.Or?

@ Nacho_dj

Hhmmm,so what want you test?So the Virtual PC was working so far for me except the problems with debugging on XP OS + the crashes with strongOD every time + graphic video driver trouble 4 colors thing.Without this I could use it.

VBox was very slow and has no HWBP for me and VMWP does not install / work correctly.So I can do what I want I get always trouble with something with the VM apps.So what can help me now?So I just need a working VM + 1 OS [XP SP0 or1] so that I can test my files + unpacking files in VM too thats all.

So I heard there is a tool where you can pack a installed target in a package + all settings file etc so that you can install this pack on a other PC which is then the same like the installed before or somthing.Maybe someone know what I mean so I dont remember the app which can do this.Maybe someone can pack his VMWare Player [3.0 not higher] or Virtual PC and can send me the pack which I can install on my PC which maybe works then for me.You know something like this so I dont know whether it works then or not you know.No idea what I can do now to prevent or fix this trouble here.Just annoying.

PS: Virtual PC 2004?So I had installed VirtualPC2007Sp1.exe :)

greetz

Share this post


Link to post
NullPointerException
So I heard there is a tool where you can pack a installed target in a package + all settings file etc so that you can install this pack on a other PC which is then the same like the installed before or somthing.

the program you are talking about is thinstall. this won't solve your problem (having vmplayer running on a portable installation is a bad idea). It's like having a vm running inside a vm.

now please can you do what i suggested from the first post? install vmware workstation 6.5 or so (the same i use today). it won't detect your corrupted vmware player installation if i remember right. your problem is probably the bad install and unistall of the previous vm software and of vmplayer. if still you cannot install it, grab sysinternals and check for registry entries that vmware check for virtualpc so that you can delete them (although at this point i'd rather do a clean windows install).

I am sure this will solve your problem. if not an hardware upgrade is suggested.

if you cannot find an old workstation installer pm me. that's all i can do.

Share this post


Link to post
LCF-AT

Hi all,

so today I gave VMWare Player the last try.I have studdy the net and tried to install it again.

1. De-Installing not possible for me

2. Re-Installing also not possible [version detected] MSI trouble too

3. Using cleaner tool VMware_Install_Cleaner.exe

4. Install again til crash at the end again

5. Using CMD with command to get the NAG with remove / repair

6. Choose repair.Successfully fixed uninstall for software panel

7. Start fixed VMWPlayer and now I get ONLY the message

--------------

Error while powering on: Internal error.

--------------

8. OS will also not start now!

9. Snout full!

10. Try to uninstall VMWP for ever!

11. Try to uninstall from software panel - get message MSI etc uninstall not possible!GREAT!

12. Force uninstall from other tool

13. Restart

14. Press keyboard any key = mouse & keyboard hangs!Can just reboot again.

15. Keyboard driver problem "yellow !" resource error (39) etc

16. Mouse has also resource error only but still works

17. Search on the net for fixing way | normal de - re install of driver not possible

18. Find solution | Reason VMWare trash in registry

{4D36E96B-E325-11CE-BFC1-08002BE10318}

UpperFilters |

--------------------

kbdclass

vmkbd2 <---- BAD BOY | Delete it

19. DeInstall Keyboard driver,reinstall keydriver,restart

20. Keyboard & mouse have no problems anymore all fine :)

21. I HATE VMWARE TRASH!

Résumé: I will no more install this soft again.I had never so much trouble with any other tool in the past.This is really crazy also that you can find so much entrys on the net with the same problems.VMWare mission totaly failed.Now I have also a trashy registry | Services which I can clean manually or with regcleaner etc.Anyway,mabye the problem are just happend with win XP SPx only so I have seen other people they using win7 has not this trouble.

Ok so lets forget the VMWare stuff so I am done with this tool now.Will better go back to Virtual-PC and give this tool a try again [maybe] or I will forget the whole VM stuff.Brings just trouble for me.I am really speechless.

@ NullPointerException

Thanks for the offer but I think this will maybe also not work for me.

greetz

Share this post


Link to post
deepzero

9. Snout full!

laugh.pnglaugh.png

Try VirtualPc2004, it`s designed for old systems and should support XP.

Besides that, spend 100-200 € on an upgrade and save yourself a lot of trouble... ;)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×
×
  • Create New...